Publié le 25 mars 2022, modifié le 26 mars 2024 par Lucie Blanchard

Le plugin Yoast WordPress SEO a publié une mise à jour, mais il est vite devenu évident que quelque chose s’était horriblement mal passé pour certains utilisateurs. Il semble que le problème ait provoqué des erreurs fatales. Les victimes négativement affectées par la mise à jour de Yoast ont dû revenir à une version précédente de Yoast.

  • La mise à jour du plugin Yoast WordPress cause des erreurs fatales
  • Problèmes de compatibilité avec la nouvelle fonctionnalité WordProof intégrée par Yoast
  • Yoast s'excuse pour les erreurs, assure que les versions suivantes sont stables et travaille sur une solution

Selon un utilisateur, son installation WordPress l’a alerté d’une « erreur fatale », selon l’e-mail qui lui a été envoyé.

Yoast a résolu le problème de manière responsable et rapide et a publié des excuses pour ce qui s’est passé.

La mise à jour du plugin Yoast version 18.4

Yoast 18.4 visait à introduire une nouvelle fonctionnalité qui introduisait des horodatages de contenu et de données structurées à des fins de protection des droits d’auteur à l’aide de la technologie blockchain.

La nouvelle fonctionnalité était connectée à un service appelé WordProof qui fournit des horodatages vérifiables indiquant aux visiteurs du site quand le contenu a été créé et mis à jour.

Échec de l’intégration de WordProof avec Yoast

Le service WordProof fournit un certificat blockchain pour certifier un horodatage et un outil de violation du droit d’auteur.

L’objectif déclaré de WordProof est de favoriser la confiance avec un site Web en fournissant des preuves et de la transparence.

Selon WordProof :

« Internet a des problèmes profondément enracinés qui grandissent chaque jour : méfiance, plagiat et fausses nouvelles. WordProof veut créer une nouvelle norme pour un Internet plus fiable et digne de confiance, avec l’aide de la technologie blockchain.

Malheureusement, l’intégration de cette fonctionnalité a entraîné un dysfonctionnement sérieux de Yoast pour les utilisateurs.

Au moment de la rédaction, certains clients de Yoast ont indiqué que cette erreur affectait les versions 18.4 et 18.4.1 de Yoast.

Selon Yoast, la version 18.4.1 du plug-in gratuit Yoast et Yoast SEO Premium 18.2.1 sont toutes deux des versions stables qui ne contiennent plus la nouvelle fonctionnalité WordProof.

WordProof est une entreprise qui indique sur sa page À propos de nous que les mari et femme cofondateurs de Yoast sont partenaires.

Symptômes de la mise à jour du plugin Bad Yoast SEO

La mise à jour condamnée du plugin Yoast WordPress SEO a provoqué des perturbations massives pour certains clients.

Problèmes typiques signalés :

  • Le plan du site XML affiche tous les types de contenu, y compris le contenu privé qui n’est pas censé être exposé
  • L’onglet des paramètres d’apparence de recherche Yoast était complètement vide
  • Message d’erreur fatale
  • WordPress envoie un message à propos de l’erreur du plugin Yoast

Un utilisateur a signalé que le cœur de WordPress avait envoyé par e-mail un message d’alerte concernant le plugin Yoast :

«Depuis WordPress 5.2, il existe une fonctionnalité intégrée qui détecte lorsqu’un plugin ou un thème provoque une erreur fatale sur votre site et vous avertit avec cet e-mail automatisé.

Dans ce cas, WordPress a détecté une erreur avec l’un de vos plugins, Yoast SEO.

L’utilisateur a partagé la documentation des mauvaises erreurs du plugin Yoast SEO :

Capture d’écran des erreurs de mise à jour de Yoast

Un autre client de Yoast a posté sur la page d’assistance publique de Yoast pour décrire ses problèmes :

« Après la mise à jour du plugin yoast seo 18.3 -> 18.4 dans la page d’état de santé du site, je peux voir quelques erreurs :

…L’API REST a rencontré une erreur Performances

…La demande de l’API REST a échoué en raison d’une erreur.

Un autre utilisateur du plugin Yoast a écrit pour informer Yoast d’une erreur similaire :

« Erreur critique après la mise à jour wordpress 5.9.2 & Yoast 18.4.1

…La demande de l’API REST a échoué en raison d’une erreur.

Un problème impliquant le problème de l’API REST semblait être une plainte assez courante, car d’autres victimes de la mise à jour de Yoast l’ont également signalé.

Un autre utilisateur du plugin Yoast a écrit que Yoast avait cassé son site Web :

« Mon site a soudainement commencé à afficher des pages vierges, des pages d’erreur, des pages formatées de manière étroite sur un navigateur de bureau (c’est-à-dire, ne prenant pas tout l’écran du navigateur comme avant), etc. Je n’ai pas non plus soudainement pu modifier ma page d’accueil… »

Autre appel à l’aide :

« Je ne parviens pas à modifier le message ou la page. Il lance une erreur. Quand j’ai désactivé le plugin. Que le problème a disparu.

…error : L’éditeur a rencontré une erreur inattendue.”

Yoast assure que la dernière version du plugin SEO est désormais stable

Le plugin a provoqué des erreurs fatales pour de nombreux utilisateurs qui ont commencé à publier sur la page de support du plugin Yoast sur WordPress.org.

Yoast a publié une déclaration d’excuses concernant la mise à jour troublée :

« Malgré des tests approfondis, certains utilisateurs ont malheureusement rencontré des problèmes avec Yoast SEO 18.4.

Comme ils ont rapidement contacté notre équipe d’assistance 24h/24 et 7j/7, nous avons pu agir rapidement et annuler cette version.

….Nous sommes désolés pour tout inconvénient que vous pourriez avoir rencontré.”

Yoast a assuré aux clients que les dernières versions (Yoast SEO 18.4.1 et Yoast SEO Premium 18.2.1) sont stables et qu’ils reviendraient sur l’intégration de WordProof à une date ultérieure.

Erreurs du plug-in Yoast SEO

Yoast n’est actuellement pas compatible avec PHP 8+. Au moins une des personnes signalant une erreur a indiqué qu’elle utilisait PHP 8.0.

Dans une question d’assistance sans rapport, quelqu’un a demandé si Yoast était compatible avec la dernière version de PHP, la version 8.x.

Le représentant du support Yoast a écrit:

« Malheureusement, nous n’avons pas encore complètement testé le plugin avec PHP version 8. Toute la communauté WordPress y travaille encore »

Il est donc possible que pour cet utilisateur particulier, PHP 8.0 ait aggravé les problèmes.

Yoast recommande de mettre à jour les dernières versions stables de leur plugin. Il peut être prudent de vérifier que votre site Web n’exécute pas PHP 8.+ et, si possible, de mettre d’abord en scène le site pour tester s’il fonctionne correctement.

Citation

Lire la déclaration de Yoast sur la mise à jour malheureuse

Yoast SEO 18.4.1 et Premium 18.2.1 disponibles maintenant

Categories: SEO

Lucie Blanchard

Lucie Blanchard

S’abonner
Notification pour
guest

Commentaires
Commentaires en ligne
Afficher tous les commentaires
0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x